re = /^(?=.*[A-Za-z])(?=.*\d)(?=.*[$@$!%*#?&])[A-Za-z\d$@$!%*#?&]{8,}$/
str = 'Margolis$1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end