const regex = /^..(.[!)3G^w]|$)|\^.{7}$|G\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^..(.[!)3G^w]|$)|\\^.{7}$|G\\)', 'gm')
const str = `The next answer has to match the following strings:
PPCG
^P
^[P^]P
[^?][PG]\$
(?<!\\\\..)(?!]).\$
^[\\w^]*\$|!|]P|G]\\\$\$
!|[^?]P(CG|G..)?\$
[^])]\\\$|^\\^?P|P.\\].\$
([.\$?]|G\\])\\\$\$|^\\^?P|\\]P\$
([P.\$?]\\\$|[]^]P|G\\]\\\$|CG)\$
!|((G.|P|\\.)\\\$|[^?]P|CG)\$
^[(!P]|G..\$|]..\\||[^?]P\$
^.{3,23}[.-~]..\\\$\$|[^P?][PG]\$
^..(.[!G)(3w^]|.{7}\$|\$)|\\\$\\?
\\.\\)|P[.\$?]|w\\^|^[^|C\\\\]*\$|^P
New string:
^..(.[!)3G^w]|\$)|\\^.{7}\$|G\\)
And fail on these strings:
[PPCG]
^[P\\^]
[^\\]]\$
^\\^?P
[^?][PG]\$|<|PG
^[^\\\\|]*(\\\\\\\\)+[^\\\\|]*[^\\]]\$
^(.{,4}|.{9}|.{16,19}|.{5}P)\$
^[^?]*[PG]\$|[?\$].*\\\$\$
^[^[]P|]P|(G]|[.])\\\$\$
\\..\$|!|\\|G|^[\\^P]P|P\\^|G.\\\$\$
...\\^.P|^!|G]\\\$\$|w|<!|^\\^?P
([^\\\\}<]{3}|][^]]|^).?[\$PG]\$
^(..[^^].{4,22}\\\$|[^?]+\\w)\$|2
^(..[^^].{4,22}\\\$|[^?]+\\w)\$|~
^..(.[!()3G^w]|.{7}\$|\$)|G\\\\
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}