#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<VirtualHost[*:0-9\s]+>([\S\s]+?)<\/VirtualHost>"
Local $sString = "..." & @CRLF & _
"# First VHost..." & @CRLF & _
"<VirtualHost *:80 *:8082>" & @CRLF & _
" # Any number of configs" & @CRLF & _
" # and set up options for" & @CRLF & _
" # Apache" & @CRLF & _
"</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"# Second VHost..." & @CRLF & _
"<VirtualHost *:80 *:8082>" & @CRLF & _
" # Any number of configs" & @CRLF & _
" # and set up options for" & @CRLF & _
" # Apache" & @CRLF & _
"</VirtualHost>" & @CRLF & _
"" & @CRLF & _
"# Third VHost..." & @CRLF & _
"<VirtualHost *:80 *:8082>" & @CRLF & _
" # Any number of configs" & @CRLF & _
" # and set up options for" & @CRLF & _
" # Apache" & @CRLF & _
"</VirtualHost>" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")