$re = '/(?<=/)[^/]{2}(?=[^/]*$)/m';
$str = 'path/stack/over_flow/Pedro_account';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);