$re = '/_(\d+)_/m';
$str = 'create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
create_sales_3920_7873
create_sales_49204_7873
create_sales_392_7873
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);