package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0*10*){4}$`)
var str = `0110101000
010110
011011011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}