re = /^(?!0\.)(?:\d{1,3}(?:,\d{3})+|\d+)(?:\.\d{1,2})?$/m
str = '1.22
0.33
100
1,000
1000
10,000
10000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end