#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!,|$)\d*(?:,\d+)*(?:\.\d+)?$"
Local $sString = "12345" & @CRLF & _
"" & @CRLF & _
".123" & @CRLF & _
"" & @CRLF & _
"23,456,789.123" & @CRLF & _
"" & @CRLF & _
"123.456.7" & @CRLF & _
"" & @CRLF & _
"--" & @CRLF & _
"12345," & @CRLF & _
"" & @CRLF & _
"123.," & @CRLF & _
"" & @CRLF & _
",123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")