$re = '/\b[0-9]{2}/m';
$str = 'asd asd 97 sasd3 54 asd98asd 10sasdal334';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);