re = /{{%(.*)}}/
str = '
À-Á-Â-Ã-Ä-Å-Æ-Ç-È-{{%É-Ê-Ë-Ì-Í-Î-Ï-Ð-Ñ-Ò-Ó-Ô-Õ-Ö-Ø-Ù-Ú-Û-Ü-Ý-Þ-ß-à-á-â-ã-ä-å-æ-ç-è-é-ê-ë-ì-í-î-ï-ð-ñ-ò-ó-ô-õ-ö-ù-ø-ú-û-ü-ý-þ-ÿ-Ā-ā-
Ă-ă-Ą-ą-Ć-ć-Ĉ-ĉ-Ċ-ċ-Č-č-Ď-ď-Đ-đ-Ē-ē-Ĕ-ĕ-Ė-ė-Ę-ę-Ě-ě-Ĝ-ĝ-Ğ-ğ-Ġ-ġ-Ģ-ģ-Ĥ-ĥ-Ħ-ħ-Ĩ-ĩ-Ī-ī-Ĭ-ĭ-Į-į-İ-ı-IJ-ij-Ĵ-ĵ-Ķ-ķ-ĸ-Ĺ-Ļ-ļ-Ľ-ľ-Ŀ-ŀ-Ł-ł-Ń-ń-Ņ-ņ-Ň-ň-ʼn-Ŋ-ŋ-Ō-ō-Ŏ-ŏ-Ő-ő-Œ-œ-Ŕ-ŕ-Ŗ-ŗ-Ř-ř-Ś-ś-Ŝ-ŝ-Ş-ş-Š-š-Ţ-ţ-Ť-ť-Ŧ-ŧ-Ũ-ũ-Ū-}}ū-Ŭ-ŭ-Ů-ů-Ű-ű-Ų-ų-Ŵ-ŵ-Ŷ-ŷ-Ÿ-Ź-ź-Ż-ż-Ž-ž-ſ-ƀ-Ɓ-Ƃ-ƃ-Ƅ-ƅ-Ɔ-Ƈ-ƈ-Ɖ-Ɗ-Ƌ-ƌ-ƍ-Ǝ-Ə-Ɛ-Ƒ-ƒ-Ɠ-Ɣ-ƕ-Ɩ-Ɨ-Ƙ-ƙ-ƚ-ƛ-Ɯ-Ɲ-ƞ-Ɵ-Ơ-ơ-Ƣ-ƣ-Ƥ-ƥ-Ʀ-Ƨ-ƨ-Ʃ-ƪ-ƫ-Ƭ-ƭ-Ʈ-Ư-ư-Ʊ-Ʋ-Ƴ-ƴ-Ƶ-ƶ-Ʒ-Ƹ-ƹ-ƺ-ƻ-Ƽ-ƽ-ƾ-ƿ-DŽ-Dž-dž-LJ-Lj-lj-NJ-Nj-nj-Ǎ-ǎ-Ǐ-ǐ-Ǒ-ǒ-Ǔ-ǔ-Ǖ-ǖ-Ǘ-ǘ-Ǚ-ǚ-Ǜ-ǜ-ǝ-Ǟ-ǟ-Ǡ-ǡ-Ǣ-ǣ-Ǥ-ǥ-Ǧ-ǧ-Ǩ-ǩ-Ǫ-ǫ-Ǭ-ǭ-Ǯ-ǯ-ǰ-DZ-Dz-dz-Ǵ-ǵ-Ƕ-Ƿ-Ǹ-ǹ-Ǻ-ǻ-Ǽ-ǽ-Ǿ-ǿ-Ȁ-ȁ-Ȃ-ȃ-Ȅ-ȅ-Ȇ-ȇ-Ȉ-ȉ-Ȋ-ȋ-Ȍ-ȍ-Ȏ-ȏ-Ȑ-ȑ-Ȓ-ȓ-Ȕ-ȕ-Ȗ-ȗ-Ș-ș-Ț-ț-Ȝ-ȝ-Ȟ-ȟ-Ƞ-ȡ-Ȣ-ȣ-Ȥ-ȥ-Ȧ-ȧ-Ȩ-ȩ-Ȫ-ȫ-Ȭ-ȭ-Ȯ-ȯ-Ȱ-ȱ-Ȳ-ȳ-ȴ-ȵ-ȶ-ȷ-ȸ-ȹ-Ⱥ-Ȼ-ȼ-Ƚ-Ⱦ-ȿ-ɀ-Ɂ-ɂ-ɃɄ-Ʌ-Ɇ-ɇ-Ɉ-ɉ-Ɋ-ɋ-Ɍ-ɍ-Ɏ-ɏ-ɐ-ɑ-ɒ-ɓ-ɔ-ɕ-ɖ-ɗ-ɘ-ə-ɚ-ɛ-ɜ-ɝ-ɞ-ɟ-ɠ-ɡ-ɢ-ɣ-ɤ-ɥ-ɦ-ɧ-ɨ-ɩ-ɪ-ɫ-ɬ-ɭ-ɮ-ɯ-ɰ-ɱ-ɲ-'
# Print the match result
str.match(re) do |match|
puts match.to_s
end