re = /(?!(.*A){4,})(?!(.*P){3,})(?!(.*L){2,})(?!(.*E){2,})(?!(.*S){2,})^[APLES]*$/m
str = 'APPLE
APPLES
PALE
ALE
APPPLE
APPLLE
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end