$re = '/(?<!\w\.\w.)(?<![A-Z][a-z]\.)(?<=\.|\?|\!)\s(?=[A-Z])/';
$str = 'Mr . john bought greatsite . com for 1 . 5 million dollars , i . e . he paid a lot for it . Did he mind ? Steve jones jr . thinks he didn\'t . In any case , this isn\'t true ... Well , with a probability of . 9 it isn\'t . What a great site ! I really loved it !!! Did you ???';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);