using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|\|(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string substitution = @"";
string input = @"abc | efg || $something(""arg 1"", ""arg 2||(a|b)"") || 123";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}