package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)A\S*X\S*B`)
var str = `AYB AXZB AZB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}