$re = '/(?<=\\\\")[^\\\\;]+/m';
$str = '"{\\"A5\\";\\"A6\\";\\"A7\\";\\"varying number of params...\\"}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);