package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)
(?:^|(?:\W)(?P<type>(?P<value>\d+)dp)(?:$|\W)
`)
var str = `33dp+23dp+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}