re = /age\s[a-z]+:\s*\d+\s*(-\s*\d+\s*(years?|months?|yrs)\/\d+\s*)+years and up/
str = 'age: adult/child gender: male/female age range: 3 - 5 years/5 - 8 years/8 - 12 years/12 years and up product type: costume character: animals & insects material: polyester theme: animal age start: 3 years age end: adult features: -face is seen through the mouth of the zebra. -zipper closure in the front and a tail in the back. -set includes: jumpsuit and head mask. -animal collection. age: -adult/child. gender: -male/female. age range: -3 - 5 years/5 - 8 years/8 - 12 years/12 years and up
\\bage[a-z]?\\b.*\\d+\\s(?:years[a-z]?|yrs|month[a-z]+)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end