$re = '/\d(?=\/)/';
$str = 'http://localhost/aspire-site/manage-users/0/tem009pdata?';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);