$re = '/[a-z]+\s((?:\d+\s?)+)/';
$str = 'foo 11 25
foo 38 15 976 24';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);