$re = '/.+(\\\\.+)$/m';
$str = 'C:\\Projects\\Ensure_Solution\\Assistance\\App_WebReferences\\Web_ERP_WebService\\Web_ERP_Assistant';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);