re = /(?<=\s)\/[a-zA-Z\/]+/
str = 'thisisgibberish 1234 /hello/world/
more gibberish 43/7 /good/timing/
just onemore 8888 /thanks/mate'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end