using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"application(?:#[^.]*)?\.xml(?:\.\d{4}-\d{2}-\d{2})?";
string input = @"application.xml
application#number.xml
application.xml.2016-01-10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}