re = /<span .+?(?=>)>/
str = '<span style="color: #0000ff">public</span> <span style="color: #0000ff">class</span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end