import re
regex = re.compile(r"<\*[\s\S]*?<\*[\s\S]*?<\*[\s\S]*?\*>[\s\S]*?\*>[\s\S]*?\*>", flags=re.IGNORECASE | re.MULTILINE)
test_str = (" <*\n"
" Comment of depth 1 containing another comment\n"
" <* \n"
" That is a comment of depth 2 containing another comment\n"
" <*\n"
" Nanananananana BATMAN!!!\n"
" *>\n"
" *> \n"
" *>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")