re = /(?<=[{,])\s*(.*?)(?=,|})/
str = '{df1_apx.fhh.irtrs.d.rrr, ffd1-afp.farr.d.rrr.asgd, ffd2-afp.farr.d.rrr.asgd}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end