package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:102[4-9]|10[3-9]\d|1[1-9]\d{2}|[2-9]\d{3}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[0-5])$`)
var str = `67892
1024
1023
112234
65535
65536
65534
10000
60000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}