import re
regex = re.compile(r"^\bhttps\b.*?\b-cat.\b\d+.", flags=re.MULTILINE)
test_str = "https://shopee.vn/%C4%90%E1%BB%93ng-H%E1%BB%93-Nam-cat.11035788.11035789"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")