$re = '/(?:en|es)\/(.*)(.*\.html)/m';
$str = 'https://www.example.com/en/page.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);