$re = '/[1-9]{1}[0-9]*/';
$str = '13Foo';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);