// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\r\n](# DO NOT TOUCH BEGIN[\n\r])?auto[ \t]+vmbr10[ \t]*[\n\r](?:[ \t]*.*[\n\r])*?[ \t]*bridge_maxwait[ \t]+0[ \t]*([\n\r]# DO NOT TOUCH END[\n\r])?").unwrap();
let string = "auto vmbr9
iface vmbr9 inet static
address 10.109.0.2
netmask 255.255.0.0
bridge_ports none
bridge_stp off
bridge_fd 0
bridge_maxwait 0
auto vmbr10
iface vmbr10 inet static
up echo 1 > /sys/devices/virtual/net/vmbr10/bridge/multicast_snooping
up echo 0 > /sys/class/net/vmbr10/bridge/multicast_querier
address 10.111.0.2
netmask 255.255.0.0
bridge_ports none
bridge_stp off
bridge_fd 0
bridge_maxwait 0
post-up ip addr add 10.111.0.254/16 dev vmbr10";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}