re = /^\D*(?<number>0*(?<nonzeros>\d+))(?<suffix>.*)$/m
str = 'GE000123-Example
F000123
SEE000000Test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end