package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+-\d+$`)
var str = `10
10-20
h-g
10-20-
10-20-30`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}