re = /^(?=.*?\d)(?=.*?[a-z])[-\wáàâäãåçéèêëíìîïñóòôöõúùûüýÿæœÁÀÂÄÃÅÇÉÈÊËÍÌÎÏÑÓÒÔÖÕÚÙÛÜÝŸÆŒ0\d!@#$%^&*()+{}:"<>?|\[\];',.\/\x5c~]{6,30}$/m
str = '9Gq!Q23Lne;<||.\\\'/\\'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end