$re = '~^(?!(?:.*/){2})(?!.*[.][.]/)\S+$~m';
$str = 'works
doesn\'t work
works/test
doesn\'twork/test/test
doesn\'twork../test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);