import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^type=AVC msg=audit\\((?<time>\\w+).*: apparmor=\\\"(?<resolution>\\w+)\\\" operation=\\\"(?<operation>\\w+)\\\"( profile=\\\"(?<profile>[^ ]+)\\\"){0,1}( name=\\\"(?<name>[^ ]+)\\\"){0,1} pid=(?<pid>\\d+) comm=\\\"{0,1}(?<comm>[^ ]+)\\\"{0,1}( requested_mask=\\\"(?<requested_mask>\\w+)\\\" denied_mask=\\\"(?<denied_mask>\\w+)\\\" fsuid=(?<fsuid>\\d+))?|^type=(?<type>\\w+) msg=audit\\((?<time1>\\w+).*: pid=(?<pid1>\\d+) uid=(?<uid>\\d+) .* msg='(?<message>.*)'|type=NETFILTER_CFG msg=audit\\((?<time2>\\w+).*: table=(?<table>[^ ]+) family=(?<family>\\d+) entries=(?<entries>\\d+)|type=ANOM_PROMISCUOUS msg=audit\\((?<time3>\\w+).*: dev=(?<device>[^ ]+) prom=(?<prom>\\d+) old_prom=(?<old_prom>\\d+).*)|type=DAEMON\\w+ msg=audit\\((?<time4>\\w+).*: (?<message1>.*)|type=CONFIG_CHANGE msg=audit\\((?<time5>\\w+).*: (?<message2>.*)";
final String string = "type=DAEMON_START msg=audit(1450609493.002:6827): auditd start, ver=2.4 format=raw kernel=4.3.0 auid=4294967295 pid=2491 subj=unconfined res=success";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}