import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Query_time:\\s*(?<Query_time>[0-9]+(?:\\.[0-9]+)?)\\s*Lock_time:\\s*(?<Lock_time>[0-9]+(?:\\.[0-9]+)?)[\\s\\S]*?;\\s*(?<Query>[^;]*)";
final String string = "# User@Host: ****[****] @ localhost [] Id: 10\n"
+ "# Query_time: 0.000283 Lock_time: 0.000075 Rows_sent: 1 Rows_examined: 1\n"
+ "SET timestamp=1589784518; SELECT VARIABLE_VALUE FROM INFORMATION_SCHEMA.GLOBAL_STATUS WHERE VARIABLE_NAME = 'TIME_SINCE_ZERO_CONNECTIONS';\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}