re = /[(\&&?)]?([^=]+)(==|!=|>=|<=)([^&#]+)(&&|\|\|)?/
str = 'BuilderPromo.builder_id==6&&request.id==6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end