$re = '/[^\s]+/';
$str = 'Hello I can\'t help not matching on apostrophes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);