re = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[^a-zA-Z0-9])(?!.*\s).{5,10}$/
str = '4564'
# Print the match result
str.match(re) do |match|
puts match.to_s
end