$re = '/(?=.*?(?:^|&)au=yello(?:&|$)).*?(?:^|&)rf=([^&]+)/m';
$str = 'rf=hello1&ur=bello&au=yello
au=yello&rf=hello2&ur=bello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);