package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<ul class=\"itens\"><li class=\".*?\">(.*?)<\/li><\/ul>`)
var str = `<div class="boxAssistir"><h2 class="titulo">Selecione o Player desejado para Assistir</h2><ul class="itens"><li class="video1"><div class="icon"><div class="symbol"></div></div>OpenLoad</li><li class="video2"><div class="icon"><div class="symbol"></div></div>Ok</li><li class="video3"><div class="icon"><div class="symbol"></div></div>Streamin</li><li class="video4"><div class="icon"><div class="symbol"></div></div>Vidzi</li></ul><ul class="videos"><li class="video1-code"><iframe src="https://openload.co/embed/mGJOi4WB9uU/" scrolling="no" frameborder="0" width="538" height="408" allowfullscreen="true" webkitallowfullscreen="true" mozallowfullscreen="true"></iframe></li><li class="video2-code"><iframe width="538" height="408" data-src="http://ok.ru/videoembed/83266570810" frameborder="0" allowfullscreen></iframe></li><li class="video3-code"><iframe data-src="http://streamin.to/embed-d0i8to43pywp-538x408.html" width="538" height="408" frameborder="0" scrolling="no"></iframe></li><li class="video4-code"><iframe data-src="http://vidzi.tv/embed-n6ssttynwolm-538x408.html" width="538" height="408" frameborder="0" scrolling="no"></iframe></li></ul></div>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}