$re = '/^(\S+)\s+(\d+)\s+(.*)/';
$str = 'HTTP/1.1 400 Bad Request';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);