re = /(?<=- )[^-]+$/m
str = 'One Thing - Two Things - Three Things - Four Things'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end