$re = '/(?!^_)([a-z_]{6})(?<!_$)/m';
$str = 'ex_bar
_exbar
exbar_
_test_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);