package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)font-size:\s*\d*\.?\d*\s*px;?`)
var str = `font-size: 13.4 px`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}