package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+)([a-zA-z]+)`)
var str = `22TKL;33TKL;22FBL;35TKL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}