re = /^(?=(\D*\d){3})E(.*?)(PH(.*?)AN|AN(.*?)PH)(.*?)T$/m
str = 'EXY2PHZ45ANUWT
E01234PH345AN678T
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end