$re = '/^(?:db\.[a-zA-Z0-9]+\.[a-zA-Z0-9]+\()({[^{}]*}\s*,?\s*)+/m';
$str = 'db.foobar.fooo({
asdfasdf : 2222
}, {
asdfasdf : 333
})';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);