$re = '/^(?P<_sec>.*)(\.)(?P<_mil>.*)/';
$str = '252352.345';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);