$re = '/(?:cat)|(?:dog)|(?:fish)/m';
$str = 'This is a caterpillar and that is a dogger.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);